Perché all’improvviso QuickTime Player e altre applicazioni hanno perso l’audio?

Oltre al caso di filmati per cui l’audio ha un encoding strano (ad esempio DivX che necessitano di “Divx Doctor“, vedi Faq 169) può capitare installando alcuni codec o lanciando alcuni programmi che anche filmati che prima andavano benissimo ora siano privi di audio, senza volume.

Quando si verifica questo problema anche anche altri suoni di sistema o di applicazioni risultino silenziosi, muti, dal cestino nel Finder all’invio della posta in Mail come in Entourage, fino all’audio dei video su Internet (con Safari o Firefox o altri browser) riprodotti senza suono.

La verifica da effettuare è che la frequenza dell'audio out sia settata correttamente, per fare questo:

  1. in Applicazioni/Utility lanciare “Configurazione MIDI Audio” (“Audio MIDI Setup”)
  2. nel primo pannello -“Dispositivi Audio” (“Audio Devices”)- selezionare dal menu a tendina le Proprietà per “Audio integrato” (“Built-in Audio”)
  3. in basso a destra, in “Uscita audio” (“Audio Output”), verificare che la frequenza di uscita sia correttamente impostata a “44100.0 Hz” (44.1KHz), altrimenti impostarla.
  4. chiudere “Configurazione MIDI Audio” (“Audio MIDI Setup”), e -senza bisogno di riavvio o logout- riprovare ad aprire QuickTime Player (o quale che fosse il programma che risultava muto)

Questo problema è stato riportato particolarmente a seguito di installazioni software, come Audacity.

ATTENZIONE: Le note sono inserite in modo anonimo dai visitatori del sito, e non sono state verificate da chi cura le Faq.
Nota di Masque
Nel caso non funzionasse, spesso si può risolvere il problema killando il processo coreaudiod

[ Home | Elenco delle FAQ | Risorse | Feed RSS ]